VocabReminder
Easily build a great vocabulary without studying! Now on the App Store!
Click here for more info about the app

Installing Feedzirra RSS Parser on Ubuntu 8

       

I recently watched a RailsCasts episode (http://railscasts.com/episodes/168-feed-parsing) on parsing and persisting RSS feeds using Feedzirra. It took a little setting up on Ubuntu because it relies on some libraries that aren't included with Ubuntu > 8.

The gem will fail right off the bat


gem sources -a http://gems.github.com # if you haven't already
gem install pauldix-feedzirra
Here is what I needed before I could install the gem

apt-get install libcurl3
apt-get install libxml2 libxml2-dev
apt-get install libxslt1-dev

Then go ahead and


gem install pauldix-feedzirra

Here are some other useful resources http://github.com/pauldix/feedzirra/tree/master http://ruby.zigzo.com/2009/02/15/feedzirra-installation-errors/

Tagged w/ #feedzirra #parsing #railscasts #rss #ubunturuby on rails